MailScanner 無法順利啟動的問題

今天停電重開發生了一些狀況,是Mail不會動了
因為我的Mail Server是用postfix加上MailScanner組成的
所以,已經穩穩的跑了很久了
不知道怎麼搞的,就就上網查了一下,就查到相關的解法

service MailScanner start
Starting MailScanner daemons:
incoming postfix: [ OK ]
outgoing postfix: [ OK ]
MailScanner:

**** ERROR: You must upgrade your perl IO module to at least
**** ERROR: version 1.2301 or MailScanner will not work!

解法

wget http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/IO-1.2301.tar.gz
          
tar xvfz IO-1.2301.tar.gz
cd IO-1.2301
perl Makefile.PL
make test
make install
重新再啟動服務就好
20101031 經過這樣的修正之後,還有另一個困擾我已久的問題也一併解決了

因為我們的主機會自動發一些通知信,因為通知信中帶有連結,MailScanner都會出現下類似下面的訊息

MailScanner has detected a possible fraud attempt from "192.168.XXX.YY" claiming to be

我找了相關的設定都找不到,結果處理完這個MailScanner無法啟動的問題之後,我同事跑來跟我說,信和之前長的不太一樣。
後來我知道知,Perl IO修正之後,MailScanner帶來的警告訊息也會一併被修正掉 呼終於解決了,長官抱怨這件事很久了。


无觅相关文章插件,快速提升流量

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *

*